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PART I

INTRODUCTION

.1 DOCUMENTATION

Thisisthe“quick start” guide for the FortranLint graphical user interface. For the main manual, see thefile
flintman.pdf stored in the doc subdirectory.

.2 PURPOSE

A. Functions

1

Cleanscape FortranLint is a programming tool that simplifies the debugging and maintenance of both
large and small Fortran programs.

Cleanscape FortranLint includes a source code analyzer with numerous features, including:
a.  Compatible with Fortran 77/90/95

=3

Supports vendor-specific diaects and language extensions
Runs under UNIX and Windows 98/2000/NT
Supports command-Line and Graphical User Interface (GUI)

Analyzes source files both locally and as a group

-~ o a o

Accepts different Fortran source file formats

Provides a global view to pinpoint areas requiring human programmer judgment

7 Q@

30 different command line options

Customize analysis through the use of environment variables
j.  Configuration file combines multiple command line options
k. Produces function call treesto represent the structure of Fortran programs

I. Produces symbol cross-reference tables with detailed information about all global symbols

B. Applications

1.

Cleanscape FortranLint can be used to:

a.  Check source files before compiled

b. Isolate obscure problems

c. ldentify problems before debugging is required
d. Map out unfamiliar programs

e. Enforce programming standards

C. Advantages

1

The diagnostic messages produced by FortranLint are more detailed than those produced by standard
compilers, and cover awider range of syntactic and semantic problems.

FortranLint analyzes source files both individually and as a group, and can therefore identify problems
that are beyond the scope of a compiler.

FortranLint is effective in reducing devel opment time and improves Fortran programming style.

Cleanscape FortranLint for Windows
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D. Flow of Analysis

1. Thefollowing flowchart illustrates the FortranLint analysis process:

Create New
Project

<

Use Existing
Project

Yes

Yes

Modify Analysis/
Open saved Add/Remove file Report/Misc Review report
project from project Options
PART 11 SETUP AND ACTIVATION

.1 WINDOWS

A. System Requirements

1. Hardware

a  Minimum 30MB of free hard disk space
b.  Minimum 128MB of RAM

c. Mouse

2. Software

a.  Operating Systems

1
2)
3)
4)
5)
6)

Microsoft Windows 98° and 98° SE

Microsoft Windows NT® 4.0 with Service Pack 6a (SP6a)

Microsoft Windows 2000° with Service Pack 2 (SP2)

Linux

Sun Solaris®

Other UNIX platforms

b. Web Browsers

1
2)

Microsoft Internet Explorer® 5.x or above

Netscape Navigator® 4.7x or above

3) Opera6.x or above

Cleanscape FortranLint for Windows
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B. Software Setup Procedure
1. Ingtdlation
a.  Toinstdl the package, proceed as follows:
1) Copy flintwin.exeto atemporary directory, then run the program.

2) Aninstaler window should appear. Click the Install button. This should extract a number of
files. After al files are extracted, click Exit.

3) FortranLintisnow installed. Theinstaller creates a shortcut on the desktop automatically. To
run FortranLint, double-click the shortcut.

Note: A system reboot is not required.
4) If you'd like to use the command-line version of FortranLint, two additional steps are required:
(i) Set the environment variable FLINTHOME as follows:
SET FLINTHOME=C:\PROGRA~1\CLEANSCAPE\FLINT\MAIN

(ii) Modify PATH asfollows:
PATH %FLINTHOME% ; %PATH%

Note: Under Windows 98, you may need to add double quotes as follows:
PATH ""%FLINTHOME% ;%PATH%""

2. Additional stepsfor Windows 2000

If you're going to install FortranLint under Windows 2000 as Administrator, and you want to make the
program accessible to ordinary ‘Users', some additional steps are required. For more information, see
Part V.1

3. Un-ingtallation
a  To"uninstal" the MS-Windows FortranLint package:
1) Deletethefollowing directory (including subdirectories):
C:\Program Files\Cleanscape\FLINT
2) Remove the FortranLint shortcut from the desktop

.2 UNIX

A. Software Setup Procedure
1. Instdlation

a.  Atthispoint, you should already have a FortranLint "tarbal". Thetarball will have a name similar
to:

csilint SYSTEM.tar.Z or
csilint_SYSTEM .tar.gz

For example:

Standard Linux - csilint_linux.tar.gz
libc5-based Linux - csilint_libc5.tar.gz
Sun Solaris - csilint_solaristar.Z
HPUX - csilint_hpux.tar.Z
etc.

Note: The Standard Linux version isintended for recent versions of Linux; use kernel 2.4.15 or
above. For versions of Linux that are more than two years old, use the libc5-based version.
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Copy thetarball to the /tmp directory on the target system.

Create adirectory for Cleanscape applications. For example:

Under Linux or HPUX: mkdir -p /usr/local/cleanscape
Under Solaris: mkdir -p Zopt/cleanscape
etc.

Note: If you're going to create a system directory, you'll need to log-in asroot. Otherwise, any user

account may be used.

Go to the new Cleanscape directory.

Unpack the tarball inside the new directory.

If the tarball's name ends with .tar.gz (or .tgz), use acommand similar to the following:

gzip -¢c -d < /tmp/foo.tar.gz | tar xf -
If the name ends with ".tar.Z" (or ".taz"), use acommand like this:

compress -c -d < /tmp/foo.tar.Z | tar xf -

Note: Under Linux, you can use a simple command of the following form to unpack either kind of

tarball:

tar zxf /tmp/foo.tar.gz

Set up the required environment variables.

Edit your UNIX "login" scripts (and the "login" scripts for any other users who will be running

FortranLint). Add commands similar to the following:

a. For"sh" or "bash" users:

CSIDIR=/usr/local/cleanscape
FLINTHOME=$CSIDIR/flintgui.dir/main
FLINTHOST=localhost

export FLINTHOME

export FLINTHOST
PATH=$CSIDIR:$FLINTHOME : $PATH

b. For"csh" or "tcsh" users:

setenv CSIDIR /usr/local/cleanscape
setenv FLINTHOME $CSIDIR/flintgui.dir/main
setenv FLINTHOST localhost

set path = ( $CSIDIR $FLINTHOME $path )

rehash

Cleanscape FortranLint for Windows
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Note: "CSIDIR" should specify the new Cleanscape directory created in step 3. Modify the setting
shown here as necessary.

c. After adding the appropriate commands, log out, then log-in again.

d. If youonly plan to run the GUI version of FortranLint, and you don't intend to use the command-
line version, you don’t need to set FLINTHOME or FLINTHOST. Inthiscase, the following
setup commands should be sufficient:

1) For"sh" or "bash" users:

CSIDIR=/usr/local/cleanscape
PATH=$CSIDIR:$PATH

2) For"csh" or "tcsh” users:

setenv CSIDIR /usr/local/cleanscape
set path = ( $CSIDIR $path )

rehash

Note: "CSIDIR" should specify the new Cleanscape directory created in step 3. Modify the setting
shown here as necessary.

7. You should now be able to run FortranLint in GUI mode. To do so, execute the command fl intgui.

After you "activate” the GUI (see the next section), you will also be able to run the command-line
version of FortranLint. To do so, execute the command Flint.

PART 111 ACTIVATING FortranLint
.1 ACTIVATION PROCEDURE

A. Registration Process

Thefirst time that you run the program, a registration prompt will be displayed. Y ou must "register” the
program before you can use them. Thisis a one-time process.
B. FortranLint Activation Procedure
1. If FortranLint is not registered, a dialog box will be displayed. To continue, press OK:
Error |

FartranLint iz not registered

whould you like to register now?

T . |

7 Cleanscape FortranLint for Windows
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2.

4.

5.

FortranLint registration window:

Register FortranLink |

M arne: |

Compary: I

Server Code: |3EI?2EIHSEE'I 1836 4134 230

Activation Code: |

For azziztance, contact Cleanzcape Software:;
Phaone: [B50) 324-3200
Email: activatei@clzanscape. net

k. Cancel

To obtain your activation code, contact Cleanscape Software and provide the server code listed on the
‘Register FortranLint’ window. The ‘Server Code’ is on the line with ayellow background:

To reach Cleanscape, call (650) 324-9200 or send email to activate@cleanscape.net

Enter your name, company name and the activation code. When ready, press OK:

Register FortranLink |

M arne: IY:::ur MHame

Compary: |Y|:|ur Compary

Server Code: |3EI?2EI£3ISE'I 1886 4134 230

Activation Code; |

For azzistance, contact Cleanscape Software:
Phone: [ER0) 324-9200
Email: activate@clzanzcape. net

k. | Cancel |

Confirm your registration information. When finished, press OK:

About FortranLink £

FortranLint Static Source Code Analyzer
Your Hame

'our Cormparny

Copyright [o) 1988-2002 Cleanscape Software
Yerzion 5.00.05

v, cleanscape. het

FortranLint is now registered and operational.

Cleanscape FortranLint for Windows
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PART IV RUNNING FortranLint

.1 USERINTERFACE

A. Overview
=lax|
Project File Process  Repart Help
CLEANSCAPE
Project - project] Analysis Report | Statistics | Call Tree | Cross Reference
4 o™
Add File: | Remave File | Select All | Select Mone |
iyt Opions | Sauroe Sertia | Reports | iso Optons
¥ Global Mode ™ Portability
¥ Wamings
I~ Fris
™ Dataflow analysiz
¥ Data Usage
I~ Implicit Typing
I~ ANSI MAXLOC rules
I Search LBTs first
|Rieady
B. Components
1. Program menu:
Froject  File  Procesz  Report
2. Shortcut bar:
0 =)= =l =
3. Project window:
Project - project]
-
B
4 | v
9 Cleanscape FortranLint for Windows
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4.  Project shortcut buttons:

Add File | Remove File | Select All I Select Hone ”

5. Analysis Options window:

Amalysiz Options | Source Config | Reports | Misc Options

¥ Global Mode [ Partability
v wamings AMSITT =
AMSIE0
[T Dataflow analysis DECNT
DECUMI=
¥ Datallsage DECWMS
I~ Implicit Typir =Pl
PICE TApind HPLX
[T ANSI MaxLOC rules LAHEY
. SGI
[~ Search LET s first SUN
WasLTRIX 3

6. Source Configuration options window:

Analysiz Options | Source Config | Reports | Misc Options

[ DebugLines [T Two-byte INTEGEFRs
[T 132 Columnsz [ lgnore IMCLUDE paths
[ HFF directives [ lgnore YM5 logicals
[T T preprocessor [T OpentMP directives
Language |.ﬁ.ut|:|mati|: 4
Dialect |.-ﬁ-.ut|:umati|: ¥
Source Format |.-’-\-.utn:-matin:: ¥
"lnclude"” directories: Erowse. .

10

Cleanscape FortranLint for Windows
Quick Start Guide



7.

8.

9.

Report options window:

Analysiz Options | Source Config | Reports | Misc Options

V' Statistics V¥ Call Tree
[ Source Listing W Condenze Tree
¥ Crosz-Reference [T Sguash Tree
' Abridged [~ SonTres
" Free Form ¥ Trim Tree
= Tabular [ Mo Libramy
[ Lower case [ Mo Undefined

Calar; IEIue g v futc-save reports
Width; I
Iath: | 75 v Autcload reports

¥ Clip long paths

Misc. options window:

Analyziz Options | Source Config | Reports | Mizc Options

Define symbols:

|nu:u_unreferenu:ed_parameters ho_unuged_commaon_taria

Indefine symbals:

Call Tree Roots:

Crozz Reference Filkers:

Dizable theze mezzages:
|76 207 261 176
Enable theze meszages:

Report windows:

Analysis Report | Statistics | Call Tree | Cross Reference

11
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C. Creating anew project

1. To create anew project, select Project/New from the menu or press the New Project button on the
shortcut bar

Note: If aproject is already open, adialog box will prompt you to save the old project first.

Project  File  Procesz  Report

Cpen

Cloze

Save

Save &z,

Exit
| —

2. A new project name appearsin thetitle:

Project - project]

D. Opening an existing project

1. Toopen an existing project, select Project/Open from the menu or press the Open Project button on the
shortcut bar:

Project  File  Procesz  Report

=

* Cloze g ————————

Save
Save bz

W)

Exit

or

2. The Open window will appear:

2%

Laak, ik Ia rhain j - cF B

] help
[:I icons
[:I reparts

File mame: || j Open I
Files of type: |FortranLint Project Files [* csi) j Cancel |

P

12 Cleanscape FortranLint for Windows
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a.  Sdect aproject file (filename.csi) from the browse window.

b.  When ready, press Open:

3. Filesassociated with the project are displayed in the file listing window:

Froject - projectl

C:“Frogram Fileg\Cleanscapetflinthexarnple

4| [+

Add File Remowve File | Select All I Select None

E. Saving project

1. Tosavethe current state of a project, select Project/Save from the menu or press the Save Project button
on the shortcut bar

Project File  Proceszs  Report

e
Dpen
Cloze

Save bz, !

Enit

=

13 Cleanscape FortranLint for Windows
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2. If thisisanew project, the Save Aswindow will appear.

savens 2| %]
Save in: I@flint j ] cF B~

[:I examples
b

| Imain

| site

File name: Iploiecﬂ j Save I
j Cancel |

2

Save as ype: I FoartrarLint Project Files [*.csi)

a.  Enter aname for the project.

File narne: Iprniect'l j

b.  When done, press the Save button:

Save

F. Modifying project
1. Adding filesto aproject

a  Toadd one or morefilesto aproject, select File/Add File from the menu to add files into the
project or press the Add File button on the project shortcut bar:

Project  File  Procesz  Repart

Froject - Import
E =port —
Select Al .
Select Hone Add File |
or
14 Cleanscape FortranLint for Windows
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b. The Add file window will appear:

Add files to project 2]
Loak in: I@ examples j - =% BB

Histary

File name: IdemoSD j Open I
Filez of twpe: I Fortran files j Cancel |

2

c. Toadd Fortran source files to a project, use Add File on the File menu, or press the Add File
button.

1) Thefile-selection dialog supports multiple-file selection under both MS-Windows and UNIX.
2) Toadd multiplefilesindividualy: use <Control> + Left Mouse Button.

3) Toaddagroup of files:
(i) Left-click onthefirst file
(ii) Hold down <Shift> + Left Mouse Button
(iii)Drag the mouse.

4) When done, press the Save button:

2. Removing files from a project

Project - project1

C:%\Program FileshCleanscapehflinteramplez\demad0.f30

4 [+

Add File Remove File I Select All I Select Mone

a.  Toremoveindividua source filesfrom a project, select the files to be removed (as explained in the
preceding section), then press the Remove File button.

15 Cleanscape FortranLint for Windows
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b. Toremoveall filesfrom a project (i.e., to clear thefile list), press Select All, then press Remove
File.

Project  File  Procesz  Report

@ At File

Project - Jmport
Export

Select Al

Select Mone Femove File |
or

c. Thefollowing dialog box will appear:

Question i

Remove selected file[z] from project’?

e — |

d. Toremove the selected files, press the OK button.
e. Theupdated filelist will be displayed in the project window:

Project - project]

1| | +]

Add File Remove File I Select All I Select Hone

G. Executetest
1. Create anew project or open an existing project for testing.
To create a new project, see section 111.2.B.

To open an existing project, section 111.2.C.

16 Cleanscape FortranLint for Windows
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2. Select thefilesto be analyzed as explained in Section IV.F.1:
Project File  Process  Feport
Add File
D | Rermove File
Irnpart

Export
C:AProgi sl htheran

Select Hone ! |

3. Moaodify options as necessary:

E

Project -

Select All I

or

Analysis Options | Source Config | Reports | Misc Cptions

v Global Mode [ Portability
V¥ wiarnings SMNSITY 1=
AMSIS0
[~ Data-flow analysis DECMT
DECLUMI=
¥ Data Usage DECYMS
I~ Implicit Typi EPE
mplicit Typing I
[~ &NSI MAXLOC ules LAHEY
. SGI
[ Search LBTs first SN
LI TR ;l

4. To analyze the selected files, use Process/Analyze Files from the menu or press the Execute test button
on the shortcut bar:

Project  File Prozcesz  Repart

=

H. Review reports

a. Toview the generated reports, use the report tabs:

Anzlysis Report | Statistics | Call Tres | Cross Reference

b.  To print reports, or to save them to disk, use the Report menu at the top of the screen. Reports may
be printed or saved collectively or individually.

17 Cleanscape FortranLint for Windows
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c. Sample Analysis Report:

#Analysis Report | Statistics | Call Tree | Cross Refaré\tne |
13
14 CONTAINS
15 1 - Internal subprograns
1g SUEROUTINE M_INMER(TYPEL, TYPEZ)
17 TYPE (MYTYPE), INTENT(INOUT) TYPEL
12 TYPE (MYTYPE}, INTENT(IN} iz TYPEZ
13 TTPEL14#NAME = 'ALIAZ: ' f/ TTYPEZ4NAME
z0 END SUBROUTINE M_INNER
z1
Z2Z END MODULE
23
24
ZE EUBLOUTINE OQUTER(TYPEL, TYPEZ, OPLUM)
=0 Declaration -----
z7 UZE M, OHNLY : MYTYPE
8 TYPE (MYTYPE], INTENT(INOUT) :: TYPELl, TYPEZ
z3 INTEGER, OPTIONAL :: OQPDUM
20 ! - Double TYPEZ's scores.
31 if ( DRESENT (OPDUM) ) THEN
32 TYPEL#ECORES (1, 1) = TYPEZ4#SCORES(1) * OPDIM
33 ELSE
34 TYPEL#SCORES (1, 1) = TYPEZH3CORES(1l, 1) * Z i
35 ENDIF
36 END SUBROUTINE
37
38 PROGERAM MATN
FORTRAN-lint {source analysis) Page 2
I Main program ——---—-——-
40
41 USE M, TYPE_Z =» MYTYPE, &
4z MYLOC == LOC !private module entities cannot be accessed
43 CHAPACTER(LEN = 10) 2TR
44 TYPE (TYPE_Z} ZTUDENT1, STUDENTZ
45
46 CALL M_INNER{STUDENT1, STUDENTZ)
47 CaLL OUTER({STUDENT1, STUDENTZ)
48 ST = CGRADE(Z)
il
d. Sample Statistics report:
Analysis Report I Statistics | Call Tree | Cross Reference
FORTRAN-lint Rev 4.37.14 03-May-2002 14:35:51 Page 1 -~
==» Etatistics:
Mumber of source files: 1
Source files: £4 lines, 1272 bytes { 18% comments, 22Z% code )
Include files: 14 lines, FEZ bytes { E% comments, 28% code )
Total parsed: 68 lines, 1625 bytes { 15% comments, 2E% code )
Total subprograms: 5
Subroutines: z
Functions: 1
Program: 1
Block Data: o
Module: 1
Individual message summary
USACE ERR flZe-— lx: local wariable * iz referenced but never set.
USACE WARN #127- lx: local wariable * iz set but never referenced.
SYNTAR ERR #1e8- lx: array referenced with too few subscripts.
INTDFC ERR §25Z- lx: * array passed to dumwmy arg which is a * array.
SYNTAX ERR fE6l- lx: entity not accessible in module *.
USACE WADN #743- lx: module entity set but not referenced: *, *
Total messages: &
BErrors Warnings  FYIs
Syntan: z 0 <=supp>
Interiace: 1 0 =supp>
Data usage: 1 z  asupp>
Implicit typing: <supp>
4 (|
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e

f.

Sample Call Tree report:

Analysis Report | Statistics | Call Tree | Cross Reference

FORTEAN-Llint Rev 4.37.14 09-May-Z00Z 14:35:51  Page 1 1=
This is & primary tree starting at the progran 'MAIN'

MATH-+-H
l—u_:mmn
l— OUTER--}
l— [MAIN_INNER]

K|

4 [+

Sample Cross Reference report:

Analysis Report | Statistics | Call Tree | Cross Reference

FORTRAN-Lint Rev 4.37.14 09-May-2002 14:35:51  Page L
serrrret SYMEOL TAELE ##+s+sss
#*% Drogram:

MAIN : defined at line 228 of C:3\Progra~liCleanscape’ flintiexanplesidencd0. £30
Calls- demc90. £50:M, demcd0. £30:M::M INNELR,
demoS0. £30: 0UTER, demcS90. £90:MATN: :MAIN INNER

**¥* Bubroutines:

M_TMNER : M internal : defined at line 16 of C:WProgra~1hWCleanscape'\ flintlexanplestdeno!
Ahrgs- (type MYTYPE £, type MYTYPE R)
Called by- dewoS0.£fS0:MAIN
OUTER : defined at line Z§& of C:\Progra~liCleanscape’flintiexamplesidenc?0. £30
Args- itype MYTYPE S, type MYTYPE B, I*4 RO)
Calls- demo30. £30:H
Called by- dewoS0.£fS0:MAIN

*** Functions:

INT : I*4 : intrinsic function
Called by- demoS0.f30:MATN::MATN_ TNMNER
EINI : I*4 [ intrinsic function
Called by- demoS30.{30:MATN: :MATN TINMER
MAIN INMNER : I*4 : MAIN internal : defined at line 53 of C:%\Progra~liCleanscapelflintie:
Args- (B*4 array R}
Called by- demoS0. £30:MATN
PREZENT : L*4 : intrinsic function
Called by- demoS0. £50:0UTER
SIZE : I*4 : intrinsic function
Called by- demo20.f30:MAIN: :MATIN INNER

FORTRAN-lint {symbol table - Modules) Page Z
**¥* Modules:

M : defined at line 3 of C:ZIrogra~1liCleanscgpeh flintexamples)dencd0. £30

4 |

19

Cleanscape FortranLint for Windows

Quick Start Guide



I. Online Help

1. Accessing the Help System

a.  Toaccessthe online help system, select Help/Contents and Index from the menu or press the Help

b.

button:

Help

CAPE

Change license key

E-mail Cleanzcape Software

Aot Fartranbint
Cleanscape Software Homepage

The FortranLint Help browser will appear:

=

Back | Forward | Home | Top | Bottom | Reload Exit
Topics
2. Anlysis options 4[5 Anatysis options -

1. Overview 31 Overview

3.2 Local mode and global mode
2.3, Wanings and F¥ls

2 4. Data-Flow Analysis Local mode
2.5 Data Usage

Foriranl int provides the following analysis modes and options

- Intra-module checking

26 Truplicis Typing Global mode - Add inter-module tests

27, ANSI MAXLOC rules Uarninogs - Report problems (only)

2.3, Search LETSs first

2.9. Portability checking FYIs - hdd "informavional” messages

" Dats-floy anslvsis - Perforn data-flow analysis

sevious

et Data Usase - Reference/set problems, etc.
Inplicit Typing - Report un-typed variables
ANSI MAXLOC rules - Modified MAXLOC/MINLOC rules

_|sesrch 1ETs first - Check IBTs before intrinsics

|«
L

J. Sub-Menu Functions

1. Copy (Microsoft Windows Only)

a
b.

Press the right mouse button inside reports frame

Select Edit -> Copy

e
Project  File  Process  Report Help

CLEANSCAPE
Foizei- e seipi= Rapot | staistos | ool en | cross Retrance
L [Formrantine rev az71a 09-May-2002 14:35:51  Page 1 =
Thiz i: & prinary tres starting s the prograw 'HATN'
+-1_nmER
— e
= Select Al
= L ect i
< o]
AddFie | Fiemove Fie | Select &l | Select None,
etz o | ource o | et | wizceaneaus
IV Giobal Mode: I Portabity
I~ Wanings
I~ Pl
I Dataflow analysis
IV DataUsage
I~ implict Typing
T ANSI MAXLOC ies
I SearchLBTS first
il o

[roiect! - Anabzed
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The image can now be pasted into other applications (for example, Microsoft Word):
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A Font...
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@, Hyperlink.
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2. Search

a
b.

Select Search -> Fi

nd

Press the right mouse button inside a report frame

e
Project  File  Process  Report Help
(CLEANSCAPE

Froject - poiect]

sy Roport | Sstistos | cal Tes | Croze Rafarance

C:\Program Fies'Ch 50 ~||ForTRAN-Line Rev 4.37.14 09-May-2002 14:35:51  Page 1 =
:
=i 3 MODULE 1
. | _
ER =
Add Fils | Fiemove File | SeloctAll | Seloct None S g (HDT4l SCORES(Z.Z)
ety Ot | source Gonig | Reports | wscelianeus 3 pm, pmoaTs Loty ]
0 INTEGER AV Fin Brevious
D mmea? e e
¥ GlobalMode. I Patabilly iz PARMINTIR (SHDE - (/A . o
I~ Wamings 14 CONTAINS
I fs 16  SUBROUTINE M_INNER(TYPEL, TYPEZ)
I~ Dataflow analysis 18 TYPE (MYTYPE), INTENT(IN) TYPEZ
¥ DataUsage 20  BND SUBROUTINE M_INNER
W iz [og—
T~ ANSI MAXLOC rues :
I~ SeachLETS fis e -
kil
|project - Analyzed
Enter string to search and select the desired options
1ol x|
Direction: Mode: Casze:
= fonward f* _oxact (% .case
" -backward " jegexp " -nocase
Fird
jiumi
Find Al
3. LineWrap
a.  Presstheright mouse button inside a report frame
b. Select View -> Wrap. The default isNone.
S
Project  File  Process Report Help
(CLEANSCAPE
Project - project! sralysis Report | statistics | Call Trem | Cross Reference
||ForTRAN-Line Rev 4.37.14 09-May-2002 14:35:51  Page 1 =

Kl

Add File | Remave File | Select Al | Select None.

[>]

V' GlobalMode: I~ Potabity
I™ Warnings

s

™ Dataflow analysis
¥ DataUsage

I Impiicit Typing

T ANSI MAXLOC ndes
T SearchLBTS fist

e | Bl e

> Source amalysis:

Direstory Co\Progra~1iCleanscapey fline sxauplasy

4090, £20
File §1 ---> C:\Progra-liCleanscape)flinciexamplesidenos0. £90

10 tr demosn.gsm *r

z

3 MODULE B

4 TYPE MYTTRE i

§  CHARACTER®IO  NANE

& INTECER(KIND=4) SCORES(Z,2)

7 =D e

s

5 REAL, PRIVATE :: LOC(10)

10 INTECER AVE

11 CHARACTER*2 GRADE(S)

1z BARMMETER (GRADE = (/'A', o

1=

14 comtazvs

18 - Internal subp: .

16  SUBROUTINE M_TNNER(TYPEL, TYPEZ)

17 TYPE (MYTYPE), INTENT(INOUT) :: TYPEL

18 TYPE (MYTVPE), TNTENT(TN}

15 TYPELANANE = 'ALTAS: ' /7 TYPEZRNANE

20 END SUBROUTINE N_INNER

21

22 ENp MODULE

23

24

28 SUBROUTINE OUTER(TVPEL, TYPEZ, OPDUN)

[ p— eclaration —-——

27 USE M, ONLY : MYTYPE

28 TYPE (NYTYPE), INTRNT(LNOUT) =: TYPEL, TYPEZ

2z INTEGER, OPTIONAL :: OPDUN

[project - Analyzed
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PART V MISCELLANEOUSINFORMATION
.1 ADDITIONAL STEPS FOR WINDOWS 2000

A. Important notes
1. Thissection appliesto users running Windows 2000 who belong to the ‘Users' group, and only to that
group.
B. Details

1. For FortranLint to run correctly under Windows 2000, users must have ‘write’ and ‘modify’ access
rights to the directory “C:\Program Files\Cleanscape” and all sub-directories under it. This document
explains the procedure used to change the access rights described above.

a Loginas‘administrator’ and finish installing FortranLint for Windows

b. Double-click onthe‘My Computer’ icon

B

Cleanscape

c. Right-click on the ‘ Cleanscape' folder and select Properties from the sub-menu.

Open

Explore

Search...

Add to Winamp's Bookmark. lisk
Engueus in Winamp

Play in Winamp

sharing. ..
&€ add to archive. .
8 add to "Cleanscape.rar”
&3 Add ta Zip
&3 Add ko Cleanscape. zip

Scan with Marton Antivirus

Send To »

Cuk
Copy

Create Sharkcuk
Delete
Rename

Properties

23 Cleanscape FortranLint for Windows
Quick Start Guide



d. Select ‘ Security’ tab on the Cleanscape Properties screen:

Cleanscape Properties id 4|l cle anscape Properties: 2 x|

General | Sharing I Security I General I Sharing  Security |
D ICIeanscape Eme | i
Administrators [AR THUR Administrators]
_ €7 CREATOR OWNER ﬂl
ep e el ﬂ Power Uzers [AR THURMP ower Users)
Location: C:M\Program Files ﬂ SYSTEM
Size: 12.1 MB (12,772,637 bytes) €3 Users (BRTHURNUsers)
Size ondisk:  13.9MB [14.618,624 bytes] Permissions: Allow Deny
Contains: 820 Files, 121 Folders Full Cantrol
tadify
Created: Monday, April 02, 2001, 5:23:16 Pk Read & Execute

Lizt Folder Conterts

Attibutes: [T Read-only Advanced... | Read

I~ Hidden Wiite

Advanced... |

~ Allows inheritable permissions from parent to propagate to this
object

0K I Cancel | Appli | 0K I Cancel Apply

e. Selectthe‘'Users group and enable the ‘Modify’ and ‘Write' permission.

f.  Click the*Apply’ button.
g. Click the‘Ok’ button. This should close the Cleanscape Properties window.
h.  FortranLint is now ready to run on Windows 2000 for the ‘Users’ group.
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	INTRODUCTION
	DOCUMENTATION
	PURPOSE
	Functions
	Cleanscape FortranLint is a programming tool that simplifies the debugging and maintenance of both large and small Fortran programs.
	Cleanscape FortranLint includes a source code analyzer with numerous features, including:
	Compatible with Fortran 77/90/95
	Supports vendor-specific dialects and language extensions
	Runs under UNIX and Windows 98/2000/NT
	Supports command-Line and Graphical User Interface (GUI)
	Analyzes source files both locally and as a group
	Accepts different Fortran source file formats
	Provides a global view to pinpoint areas requiring human programmer judgment
	30 different command line options
	Customize analysis through the use of environment variables
	Configuration file combines multiple command line options
	Produces function call trees to represent the structure of Fortran programs
	Produces symbol cross-reference tables with detailed information about all global symbols


	Applications
	Cleanscape FortranLint can be used to:
	Check source files before compiled
	Isolate obscure problems
	Identify problems before debugging is required
	Map out unfamiliar programs
	Enforce programming standards


	Advantages
	The diagnostic messages produced by FortranLint are more detailed than those produced by standard compilers, and cover a wider range of syntactic and semantic problems.
	FortranLint analyzes source files both indi˜vidually and as a group, and can therefore identify problems that are be˜yond the scope of a compiler.
	FortranLint is effective in reducing development time and improves Fortran programming style.

	Flow of Analysis
	The following flowchart illustrates the FortranLint analysis process:



	SETUP AND ACTIVATION
	WINDOWS
	System Requirements
	Hardware
	Minimum 30MB of free hard disk space
	Minimum 128MB of RAM
	Mouse

	Software
	Operating Systems
	Microsoft Windows 98® and 98® SE
	Microsoft Windows NT® 4.0 with Service Pack 6a \
	Microsoft Windows 2000® with Service Pack 2 \(S�
	Linux
	Sun Solaris®
	Other UNIX platforms

	Web Browsers
	Microsoft Internet Explorer® 5.x or above
	Netscape Navigator® 4.7x or above
	Opera 6.x or above



	Software Setup Procedure
	Installation
	To install the package, proceed as follows:
	Copy flintwin.exe to a temporary directory, then run the program.
	An installer window should appear.  Click the Install  button. This should extract a number of files. After all files are extracted, click Exit.
	FortranLint is now installed.  The installer creates a shortcut on the desktop automatically.  To run FortranLint, double-click the shortcut.
	Note:  A system reboot is not required.
	If you'd like to use the command-line version of FortranLint, two additional steps are required:
	Set the environment variable FLINTHOME as follows:
	Modify PATH as follows:



	PATH %FLINTHOME%;%PATH%
	Note:  Under Windows 98, you may need to add double quotes as follows:
	PATH "%FLINTHOME%;%PATH%"
	Additional steps for Windows 2000
	Un-installation
	To "uninstall" the MS-Windows FortranLint package:
	Delete the following directory (including subdirectories):
	Remove the FortranLint shortcut from the desktop




	UNIX
	Software Setup Procedure
	Installation
	At this point, you should already have a FortranLint  "tarball".  The tarball will have a name similar to:

	Copy the tarball to the /tmp directory on the target system.
	Create a directory for Cleanscape applications. For example:
	Go to the new Cleanscape directory.
	Unpack the tarball inside the new directory.
	Set up the required environment variables.
	Edit your UNIX "login" scripts  (and the "login" scripts for any other users who will be running FortranLint).  Add commands similar to the following:
	For "sh" or "bash" users:
	CSIDIR=/usr/local/cleanscape
	FLINTHOME=$CSIDIR/flintgui.dir/main
	FLINTHOST=localhost
	export FLINTHOME
	export FLINTHOST
	PATH=$CSIDIR:$FLINTHOME:$PATH
	For "csh" or "tcsh" users:
	setenv CSIDIR /usr/local/cleanscape
	setenv FLINTHOME $CSIDIR/flintgui.dir/main
	setenv FLINTHOST localhost
	set path = ( $CSIDIR $FLINTHOME $path )
	rehash
	Note:  "CSIDIR" should specify the new Cleanscape directory created in step 3. Modify the setting shown here as necessary.
	After adding the appropriate commands, log out, then log-in again.
	If you only plan to run the GUI version of Fortra
	For "sh" or "bash" users:
	CSIDIR=/usr/local/cleanscape
	PATH=$CSIDIR:$PATH
	For "csh" or "tcsh" users:
	setenv CSIDIR /usr/local/cleanscape
	set path = ( $CSIDIR $path )
	rehash
	Note:  "CSIDIR" should specify the new Cleanscape directory created in step 3. Modify the setting shown here as necessary.


	You should now be able to run FortranLint in GUI mode.  To do so, execute the command flintgui.
	After you "activate" the GUI (see the next section),  you will also be able to run the command-line version of FortranLint. To do so, execute the command flint.



	ACTIVATING FortranLint
	ACTIVATION PROCEDURE
	Registration Process
	FortranLint Activation Procedure
	If FortranLint is not registered, a dialog box will be displayed.  To continue, press OK:
	FortranLint registration window:
	To obtain your activation code, contact Cleanscap
	Enter your name, company name and the activation code.  When ready, press OK:
	Confirm your registration information.  When finished, press OK:
	FortranLint is now registered and operational.



	RUNNING FortranLint
	USER INTERFACE
	Overview
	Components
	Program menu:
	Shortcut bar:
	Project window:
	Project shortcut buttons:
	Analysis Options window:
	Source Configuration options window:
	Report options window:
	Misc. options window:
	Report windows:

	Creating a new project
	To create a new project, select Project/New from the menu or press the New Project button on the shortcut bar
	A new project name appears in the title:

	Opening an existing project
	To open an existing project, select Project/Open from the menu or press the Open Project button on the shortcut bar:
	The Open window will appear:
	�
	Select a project file (filename.csi) from the browse window.
	When ready, press Open:

	Files associated with the project are displayed in the file listing window:
	�

	Saving project
	To save the current state of a project, select Project/Save from the menu or press the Save Project button on the shortcut bar
	If this is a new project, the Save As window will appear.
	Enter a name for the project.
	�
	When done, press the Save button:


	Modifying project
	Adding files to a project
	To add one or more files to a project, select File/Add File from the menu to add files into the project or press the Add File button on the project shortcut bar:
	The Add file window will appear:
	To add Fortran source files to a project, use Add File on the File menu, or press the Add File button.
	The file-selection dialog supports multiple-file selection under both MS-Windows and UNIX.
	To add multiple files individually:  use <Control> + Left Mouse Button.
	To add a group of files:
	Left-click on the first file
	Hold down <Shift> + Left Mouse Button
	Drag the mouse.

	When done, press the Save button:


	Removing files from a project
	To remove individual source files from a project, select the files to be removed (as explained in the preceding section), then press the Remove File button.
	To remove all files from a project (i.e., to clear the file list), press Select All, then press Remove File.
	The following dialog box will appear:
	To remove the selected files, press the OK button.
	The updated file list will be displayed in the project window:


	Execute test
	Create a new project or open an existing project for testing.
	To create a new project, see section III.2.B.
	To open an existing project, section III.2.C.
	Select the files to be analyzed as explained in Section IV.F.1:
	Modify options as necessary:
	�
	To analyze the selected files, use Process/Analyze Files from the menu or press the Execute test button on the shortcut bar:

	Review reports
	
	To view the generated reports, use the report tabs:
	�
	To print reports, or to save them to disk, use the Report menu at the top of the screen. Reports may be printed or saved collectively or individually.
	Sample Analysis Report:
	Sample Statistics report:
	Sample Call Tree report:
	Sample Cross Reference report:


	Online Help
	Accessing the Help System
	To access the online help system, select Help/Contents and Index from the menu or press the Help button:
	The FortranLint Help browser will appear:


	Sub-Menu Functions
	Copy (Microsoft Windows Only)
	Press the right mouse button inside reports frame
	Select Edit -> Copy
	The image can now be pasted into other applications (for example, Microsoft Word):

	Search
	Press the right mouse button inside a report frame
	Select Search -> Find
	Enter string to search and select the desired options

	Line Wrap
	Press the right mouse button inside a report frame
	Select View -> Wrap.  The default is None.
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