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PART I INTRODUCTION 

.1 DOCUMENTATION 
 

This is the “quick start” guide for the FortranLint graphical user interface.  For the main manual, see the file 
flintman.pdf stored in the doc subdirectory. 

.2 PURPOSE  

A. Functions 

1. Cleanscape FortranLint is a programming tool that simplifies the debugging and maintenance of both 
large and small Fortran programs. 

2. Cleanscape FortranLint includes a source code analyzer with numerous features, including: 

a. Compatible with Fortran 77/90/95 

b. Supports vendor-specific dialects and language extensions 

c. Runs under UNIX and Windows 98/2000/NT 

d. Supports command-Line and Graphical User Interface (GUI) 

e. Analyzes source files both locally and as a group 

f. Accepts different Fortran source file formats 

g. Provides a global view to pinpoint areas requiring human programmer judgment 

h. 30 different command line options 

i. Customize analysis through the use of environment variables 

j. Configuration file combines multiple command line options 

k. Produces function call trees to represent the structure of Fortran programs 

l. Produces symbol cross-reference tables with detailed information about all global symbols 

B. Applications 

1. Cleanscape FortranLint can be used to: 

a. Check source files before compiled 

b. Isolate obscure problems 

c. Identify problems before debugging is required 

d. Map out unfamiliar programs 

e. Enforce programming standards 

C. Advantages 

1. The diagnostic messages produced by FortranLint are more detailed than those produced by standard 
compilers, and cover a wider range of syntactic and semantic problems.  

2. FortranLint analyzes source files both individually and as a group, and can therefore identify problems 
that are beyond the scope of a compiler.   

3. FortranLint is effective in reducing development time and improves Fortran programming style. 
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D. Flow of Analysis 

1. The following flowchart illustrates the FortranLint analysis process: 
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PART II SETUP AND ACTIVATION 

.1 WINDOWS 

A. System Requirements 

1. Hardware 

a. Minimum 30MB of free hard disk space   

b. Minimum 128MB of RAM  

c. Mouse 

2. Software 

a. Operating Systems 

1) Microsoft Windows 98® and 98® SE 

2) Microsoft Windows NT® 4.0 with Service Pack 6a (SP6a) 

3) Microsoft Windows 2000® with Service Pack 2 (SP2) 

4) Linux 

5) Sun Solaris® 

6) Other UNIX platforms 

b. Web Browsers 

1) Microsoft Internet Explorer® 5.x or above 

2) Netscape Navigator® 4.7x or above 

3) Opera 6.x or above 
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B. Software Setup Procedure 

1. Installation 

a. To install the package, proceed as follows: 

1) Copy flintwin.exe to a temporary directory, then run the program. 

2) An installer window should appear.  Click the Install  button. This should extract a number of 
files. After all files are extracted, click Exit. 

3) FortranLint is now installed.  The installer creates a shortcut on the desktop automatically.  To 
run FortranLint, double-click the shortcut.   

Note:  A system reboot is not required. 

4) If you'd like to use the command-line version of FortranLint, two additional steps are required: 
(i) Set the environment variable FLINTHOME as follows: 

 
SET FLINTHOME=C:\PROGRA~1\CLEANSCAPE\FLINT\MAIN 

 
(ii) Modify PATH as follows: 

PATH %FLINTHOME%;%PATH% 

Note:  Under Windows 98, you may need to add double quotes as follows: 

PATH "%FLINTHOME%;%PATH%" 

2. Additional steps for Windows 2000 
 

If you’re going to install FortranLint under Windows 2000 as Administrator, and you want to make the 
program accessible to ordinary ‘Users’, some additional steps are required.  For more information, see 
Part V.1 

3. Un-installation 

a. To "uninstall" the MS-Windows FortranLint package: 

1) Delete the following directory (including subdirectories): 
 

C:\Program Files\Cleanscape\FLINT 
2) Remove the FortranLint shortcut from the desktop 

.2 UNIX 

A. Software Setup Procedure 

1. Installation 

a. At this point, you should already have a FortranLint  "tarball".  The tarball will have a name similar 
to: 

 
csilint_SYSTEM.tar.Z      or 

       csilint_SYSTEM.tar.gz 
 

For example: 
 

Standard Linux      - csilint_linux.tar.gz 
libc5-based Linux   - csilint_libc5.tar.gz 
Sun Solaris     - csilint_solaris.tar.Z 
HPUX  - csilint_hpux.tar.Z 

        etc. 
 

Note: The Standard Linux version is intended for recent versions of Linux; use kernel 2.4.15 or 
above. For versions of Linux that are more than two years old, use the libc5-based version. 
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2. Copy the tarball to the /tmp directory on the target system. 
 

3. Create a directory for Cleanscape applications. For example: 
 

Under Linux or HPUX: mkdir -p /usr/local/cleanscape 
Under Solaris: mkdir -p /opt/cleanscape 
etc. 

 
Note: If you’re going to create a system directory, you’ll need to log-in as root. Otherwise, any user 
account may be used. 

 

4. Go to the new Cleanscape directory. 
 

5. Unpack the tarball inside the new directory. 
 

If the  tarball's name ends with .tar.gz (or .tgz),  use a command similar to the following: 
 

gzip -c -d  < /tmp/foo.tar.gz | tar xf - 
  

If the name ends with ".tar.Z" (or ".taz"), use a command like this: 
 

compress -c -d < /tmp/foo.tar.Z | tar xf - 
 

Note:  Under Linux, you can use a simple command of the following form to unpack either kind of 
tarball: 

 
tar zxf /tmp/foo.tar.gz 
 

6. Set up the required environment variables. 

Edit your UNIX "login" scripts  (and the "login" scripts for any other users who will be running 
FortranLint).  Add commands similar to the following: 

a. For "sh" or "bash" users: 
 

CSIDIR=/usr/local/cleanscape 

FLINTHOME=$CSIDIR/flintgui.dir/main 

FLINTHOST=localhost 

export FLINTHOME 

export FLINTHOST 

PATH=$CSIDIR:$FLINTHOME:$PATH 
 

b. For "csh" or "tcsh" users: 
 

setenv CSIDIR /usr/local/cleanscape 

setenv FLINTHOME $CSIDIR/flintgui.dir/main 

setenv FLINTHOST localhost 

set path = ( $CSIDIR $FLINTHOME $path ) 

rehash 
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Note:  "CSIDIR" should specify the new Cleanscape directory created in step 3. Modify the setting 
shown here as necessary. 

 

c. After adding the appropriate commands, log out, then log-in again. 

d. If you only plan to run the GUI version of FortranLint, and you don't intend to use the command-
line version, you don’t need to set FLINTHOME or FLINTHOST.  In this case,  the  following  
setup commands should be sufficient: 

1) For "sh" or "bash" users: 
 

CSIDIR=/usr/local/cleanscape 

PATH=$CSIDIR:$PATH 
 

2) For "csh" or "tcsh" users: 
 

setenv CSIDIR /usr/local/cleanscape 

set path = ( $CSIDIR $path ) 

rehash 

 

Note:  "CSIDIR" should specify the new Cleanscape directory created in step 3. Modify the setting 
shown here as necessary. 

 

7. You should now be able to run FortranLint in GUI mode.  To do so, execute the command flintgui. 

After you "activate" the GUI (see the next section),  you will also be able to run the command-line 
version of FortranLint. To do so, execute the command flint. 

PART III ACTIVATING FortranLint 

.1 ACTIVATION PROCEDURE 

A. Registration Process 
 

The first time that you run the program, a registration prompt will be displayed. You must "register" the 
program before you can use them.  This is a one-time process.   

B. FortranLint Activation Procedure  

1. If FortranLint is not registered, a dialog box will be displayed.  To continue, press OK: 
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2. FortranLint registration window: 
 

 
 

To obtain your activation code, contact Cleanscape Software and provide the server code listed on the 
‘Register FortranLint’ window.  The ‘Server Code’ is on the line with a yellow background: 

 
To reach Cleanscape, call (650) 864-9600 or send email to activate@cleanscape.net 
            

3. Enter your name, company name and the activation code.  When ready, press OK: 
 

 
4. Confirm your registration information.  When finished, press OK: 

 

 
 

5. FortranLint is now registered and operational. 
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PART IV RUNNING FortranLint  

.1 USER INTERFACE 

A. Overview 
 

 

B. Components 

1. Program menu: 
 

 
 

2. Shortcut bar: 
 

 
 

3. Project window: 
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4. Project shortcut buttons: 
 

 
 

5. Analysis Options window: 
 

 
 

6. Source Configuration options window: 
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7. Report options window: 
 

 
 

8. Misc. options window: 
 

 
 

9. Report windows: 
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C. Creating a new project  

1. To create a new project, select Project/New from the menu or press the New Project button on the 
shortcut bar 
 
Note: If a project is already open, a dialog box will prompt you to save the old project first.  

  

 or  

2. A new project name appears in the title:  
 

 

D. Opening an existing project  

1. To open an existing project, select Project/Open from the menu or press the Open Project button on the 
shortcut bar: 

 

 or  
 

2. The Open window will appear: 
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a. Select a project file (filename.csi) from the browse window.  
 

b. When ready, press Open: 
 

 
 

3. Files associated with the project are displayed in the file listing window: 

 
 

E. Saving project 

1. To save the current state of a project, select Project/Save from the menu or press the Save Project button 
on the shortcut bar 

 

 or   
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2. If this is a new project, the Save As window will appear.  
 

 
 

a. Enter a name for the project. 
 

  
 

b. When done, press the Save button: 
 

 
 

F. Modifying project 

1. Adding files to a project 

a. To add one or more files to a project, select File/Add File from the menu to add files into the 
project or press the Add File button on the project shortcut bar: 

 

 or   
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b. The Add file window will appear: 
 

 
 

c. To add Fortran source files to a project, use Add File on the File menu, or press the Add File 
button. 
 

1) The file-selection dialog supports multiple-file selection under both MS-Windows and UNIX.  

2) To add multiple files individually:  use <Control> + Left Mouse Button.  

3) To add a group of files:  
(i) Left-click on the first file 
(ii) Hold down <Shift> + Left Mouse Button 
(iii) Drag the mouse. 

4) When done, press the Save button:  

2. Removing files from a project  
 

 
 

a. To remove individual source files from a project, select the files to be removed (as explained in the 
preceding section), then press the Remove File button. 
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b. To remove all files from a project (i.e., to clear the file list), press Select All, then press Remove 
File. 

 

  or   
 

c. The following dialog box will appear: 
 

 
 

d. To remove the selected files, press the OK button.  

e. The updated file list will be displayed in the project window: 
 

 
 

G. Execute test 

1. Create a new project or open an existing project for testing.   

To create a new project, see section III.2.B. 

To open an existing project, section III.2.C. 
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2. Select the files to be analyzed as explained in Section IV.F.1:    
 

 or   
 

3. Modify options as necessary: 
 

 
 

4. To analyze the selected files, use Process/Analyze Files from the menu or press the Execute test button 
on the shortcut bar: 

 

  or    

H. Review reports 

a. To view the generated reports, use the report tabs: 

  
 

b. To print reports, or to save them to disk, use the Report menu at the top of the screen. Reports may 
be printed or saved collectively or individually. 
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c. Sample Analysis Report: 
 

 
 

d. Sample Statistics report: 
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e. Sample Call Tree report: 
 

 
 

f. Sample Cross Reference report: 
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I. Online Help  

1. Accessing the Help System 

a. To access the online help system, select Help/Contents and Index from the menu or press the Help 
button: 

 

 or  

b. The FortranLint Help browser will appear: 
 

 

J. Sub-Menu Functions  

1. Copy (Microsoft Windows Only) 

a. Press the right mouse button inside reports frame 

b. Select Edit -> Copy  
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c. The image can now be pasted into other applications (for example, Microsoft Word): 
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2. Search 

a. Press the right mouse button inside a report frame 

b. Select Search -> Find 
 

 
 

c. Enter string to search and select the desired options 
 

 
 

3. Line Wrap 

a. Press the right mouse button inside a report frame 

b. Select View -> Wrap.  The default is None. 
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PART V MISCELLANEOUS INFORMATION 

.1 ADDITIONAL STEPS FOR WINDOWS 2000 

A. Important notes 

1. This section applies to users running Windows 2000 who belong to the ‘Users’ group, and only to that 
group. 

B. Details 

1. For FortranLint to run correctly under Windows 2000, users must have ‘write’ and ‘modify’ access 
rights to the directory “C:\Program Files\Cleanscape” and all sub-directories under it.  This document 
explains the procedure used to change the access rights described above. 

 

a. Log in as ‘administrator’ and finish installing FortranLint for Windows 

b. Double-click on the ‘My Computer’ icon on the desktop 

c. Right-click on the ‘Cleanscape‘ folder  and select Properties from the sub-menu. 
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d. Select ‘Security’ tab on the Cleanscape Properties screen: 
 

  

e. Select the ‘Users’ group and enable the ‘Modify’ and ‘Write’ permission.   

f. Click the ‘Apply’ button. 

g. Click the ‘Ok’ button.  This should close the Cleanscape Properties window. 

h. FortranLint is now ready to run on Windows 2000 for the ‘Users’ group. 
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